Tihiroの頭を休めるIT教室

少しだけ頭使って後は根性

openssl-develをインストールしようとしてもインストールできない。

概要

日々、エラー対策の毎日です。yumでopenssl-develをインストールしようとしたら、なぜかエラー。悲しい。

環境

解決策

エラー内容

Error: Package: 1:openssl-devel-1.0.1e-42.el7.9.x86_64 (base)

       Requires: openssl-libs(x86-64) = 1:1.0.1e-42.el7.9

       Installed: 1:openssl-libs-1.0.1e-51.el7_2.2.x86_64 (@updates)

           openssl-libs(x86-64) = 1:1.0.1e-51.el7_2.2

       Available: 1:openssl-libs-1.0.1e-42.el7.9.x86_64 (base)

           openssl-libs(x86-64) = 1:1.0.1e-42.el7.9

You could try using --skip-broken to work around the problem

You could try running: rpm -Va --nofiles --nodigest

openssl-libsのバージョンが新しすぎるから?

対策

ならば、バージョンダウンをすればよかろう。という話です。

yum --showduplicate list openssl

で、ダウングレードできるバージョンを調べて

yum downgrade openssl-libs

ダウングレード開始(バージョン指定したい場合は、きちんと指定しましょう)。

それから

yum install -y openssl-devel

で、インストール完了!

まとめ

@updatesってなに?